DjangoのDockerでCommandError: Can’t find msguniq. Make sure you have GNU gettext tools 0.15 or newer installed.

今回はDjangoのDockerを使っていて、「django-admin.py makemessages -l ja」などを実行したときに「CommandError: Can’t find msguniq. Make sure you have GNU gettext tools 0.15 or newer installed.」というエラーが出たときの対処法についてご紹介いたします。



DjangoのDockerでCommandError: Can’t find msguniq. Make sure you have GNU gettext tools 0.15 or newer installed.

表題の通りです。

DjangoのDockerを使用しているときに、ローカライズするために「django-admin.py makemessages -l ja」のコマンドを打ったところ、「CommandError: Can’t find msguniq. Make sure you have GNU gettext tools 0.15 or newer installed.」というエラーが出てしまいました。

Dockerを使用していない場合だと、brew installでgettextをインストールしてパスを通せば問題なく動作が完了するらしいですが、Dockerを使用しているため自分のPCでのbrew installは関係ありません。

結論を言うと、DjangoのDockerコンテナの中に入り、
apt-get update
をして
apt-get install -y gettext libgettextpo-dev
をすれば「django-admin.py makemessages -l ja」などが問題なく動作するようになります。

いちいちDockerコンテナの中に入ってビルドされるごとにコマンドを打つのも面倒なので、DockerFileに

を記載しておくと良いかもしれません。

終わりに

今回はDjangoのDockerを使っていて、「django-admin.py makemessages -l ja」などを実行したときに「CommandError: Can’t find msguniq. Make sure you have GNU gettext tools 0.15 or newer installed.」というエラーが出たときの対処法についてご紹介いたしました。

【お知らせ】
プログラミングのコンサルタントをすることを考えております。
下記の通り、かなり格安でご用意させていただいております。
【格安】プログラミングコンサル生募集(初心者向け、フリーランス志望向け)

詳しくは下記のリンクをご覧ください。
https://chico-shikaku.com/2020/10/programming-consult-2020/

11月くらいを目処に開始予定です。
最初は募集があれば先着5名くらいを目安に考えております。
質問や意見、問い合わせやお申し込みは下記のリンクよりお願いいたします。
https://docs.google.com/forms/d/e/1FAIpQLSeTXskmlyPAHuhwiOE9togqJPWdhXYCyRoVnFkkbS0VN0Ftug/viewform?usp=sf_link

最後までお読みいただきありがとうございます。
ブログやTwitterでのシェアOKです。
コメントもお待ちしております。
誤植や勘違いなどございましたらコメント欄にて教えていただけると幸いです。






Django

Posted by ちこ