npm run devで「at module.exports (node_modules/@nuxtjs/dotenv/lib/module.js:9:24)」

今回はnpm run devを叩いたときに下記のエラーが出たときの対処法についてご紹介しようと思います。

Node.jsのバージョンは16.20.2で、Nuxt.jsのバージョンは3.11.2です。



npm run devで「at module.exports (node_modules/@nuxtjs/dotenv/lib/module.js:9:24)」

結論から言うとpackage.jsonの「@nuxtjs/dotenv」を消してnpm installし直すと直ります。

Nuxt3(正確にはNuxtv2.13以降)では、@nuxtjs/dotenvの代わりにruntimeConfigを使用することが推奨されております。

もしNuxtのバージョンアップ時にこのエラーが出たなら、@nuxtjs/dotenvを使わないことを選択しても良いかもしれません。

終わりに

今回はnpm run devを叩いたときに冒頭のエラーが出たときの対処法についてご紹介いたしました。

最後までお読みいただきありがとうございます。
よろしければブログやTwitterでのシェアをお願いしております。
コメントもお待ちしております。
誤植や勘違いなどございましたらコメント欄にて教えていただけると幸いです。

直接契約ができるフリーランスエージェント「エンハンス」を立ち上げました。
詳しくは下記LPをご参照ください。
https://enhance.decryption.co.jp/

Youtubeチャンネル開設いたしました。
チャンネル登録者1000人を目指しているので、良いと思った方はチャンネル登録をお願いしたいです。
https://www.youtube.com/channel/UC219XhmSRxmXltTy6COxSMw






Nuxt.js

Posted by ちこ