coreschema install時に「ERROR: Can not execute `setup.py` since setuptools is not available in the build environment.」

今回はpip installを使ってcoreschemaをインストールしようとしたときに下記のエラーが起きたときの対処法についてご紹介していこうと思います。

動作環境はPython3.8.13で、RHEL系のLinuxディストリビューションであるAlmaLinux9.3を使用しております。



coreschema install時に「ERROR: Can not execute setup.py since setuptools is not available in the build environment.」

結論としては対処法は簡単で、

を叩けばOKです。

念のためですが、pipのパスがPython3.8などお使いのPythonに対してのパスが通っているかを確認するようにしましょう。

終わりに

今回はpip installを使ってcoreschemaをインストールしようとしたときに冒頭のエラーが起きたときの対処法についてご紹介いたしました。

最後までお読みいただきありがとうございます。
よろしければブログやTwitterでのシェアをお願いしております。
コメントもお待ちしております。
誤植や勘違いなどございましたらコメント欄にて教えていただけると幸いです。

Youtubeチャンネル開設いたしました。
チャンネル登録者1000人を目指しているので、良いと思った方はチャンネル登録をお願いしたいです。
https://www.youtube.com/channel/UC219XhmSRxmXltTy6COxSMw






Python

Posted by ちこ