「flutter pub run build_runner build」でCould not find package “build_runner”

今回は
flutter pub run build_runner build --delete-conflicting-outputs
のコマンドを叩いたときに
Deprecated. Use dart run instead.
Could not find package "build_runner". Did you forget to add a dependency?

というエラーが起きたときの対処法について書いていきます。



「flutter pub run build_runner build」でCould not find package “build_runner"

結論から言うとbuild_runnerがインストールされていないので、pubspec.yamlにbuild_runnerを記載するようにしましょう。
dev_dependenciesに記載することが多いと思います。

あとは
flutter pub run build_runner build --delete-conflicting-outputs
が問題なく動くと思います。
Deprecated. Use dart run instead.
と書いてある通り、
dart run build_runner build
とした方が良いかもしれません。

終わりに

今回は
flutter pub run build_runner build --delete-conflicting-outputs
のコマンドを叩いたときに表題のエラーが出たときの対処法について記載いたしました。

最後までお読みいただきありがとうございます。
よろしければブログやTwitterでのシェアをお願いしております。
コメントもお待ちしております。
誤植や勘違いなどございましたらコメント欄にて教えていただけると幸いです。

Youtubeチャンネル開設いたしました。
チャンネル登録者1000人を目指しているので、良いと思った方はチャンネル登録をお願いしたいです。
https://www.youtube.com/channel/UC219XhmSRxmXltTy6COxSMw






Flutter

Posted by ちこ