npm ciで「npm ERR! cipm can only install packages when your package.json and package-lock.json or npm-shrinkwrap.json are in sync」

今回はnpm ciを叩いたときに下記のエラーが出たときの原因についてお話ししていきます。

Node.jsのバージョンは10.6.0で、npmのバージョンは6.1.0です。



npm ciで「npm ERR! cipm can only install packages when your package.json and package-lock.json or npm-shrinkwrap.json are in sync」

結論から言うと、私の場合はpackage-lock.jsonの内容と、Node.js(あるいはnpm)のバージョンが合っていないことが原因でした。

例えば、Node.jsの20系でpackage.jsonを元にpackage-lock.jsonを作った後に、そのpackage-lock.jsonに対してNode.jsの10系でnpm ciをすると表題のエラーが発生します。

Node.js(あるいはnpm)のバージョンとpackage-lock.jsonを作ったときのNode.js(あるいはnpm)のバージョンが合っているか確認するようにしましょう。

終わりに

今回はnpm ciを叩いたときに表題のエラーが出たときの原因についてお話しいたしました。

最後までお読みいただきありがとうございます。
よろしければブログやTwitterでのシェアをお願いしております。
コメントもお待ちしております。
誤植や勘違いなどございましたらコメント欄にて教えていただけると幸いです。

直接契約ができるフリーランスエージェント「エンハンス」を立ち上げました。
詳しくは下記LPをご参照ください。
https://enhance.decryption.co.jp/

Youtubeチャンネル開設いたしました。
チャンネル登録者1000人を目指しているので、良いと思った方はチャンネル登録をお願いしたいです。
https://www.youtube.com/channel/UC219XhmSRxmXltTy6COxSMw






Node.js

Posted by ちこ